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Creating Web Pages with Nvu
In this tutorial, Daniel Bartholomew uses Nvu to create a small Web site for viewing family pictures.
The Nvu Web site editor provides what you see is what you get (WYSIWYG) editing in Linux.
DANIEL BARTHOLOMEW

In the early days of the World Wide Web, Web
pages were created by hand. Although this approach
still may appeal to some, I think most of us would
prefer to see our Web page as we create it.
In fact, several programs, most of them quite
expensive, exist that help you create nice-looking
Web sites graphically. Back in Netscape’s heyday, a
free Web site editor was built into the old Mozilla
browser suite, but it was abandoned when the
Mozilla development stopped. Now, thanks to
some enterprising programmers who resurrected
the old Mozilla code, we have Nvu.
Nvu is short for new view. Think of Nvu as a
word processor for Web pages. It helps you—
quickly, easily and graphically—create attractive
Web pages and entire Web sites.
The easiest way to get Nvu is through your distribution’s package manager. For example, on my
home computer, which runs Ubuntu, I simply
launched the Synaptic package manager, searched
for nvu, selected it, and then pressed the Apply
button. After the install, I found it sitting in the
Applications→Programming menu.
If you can’t find Nvu in your distribution’s package manager, go to http://www.nvu.com and click
on the Downloads link to find several packages
that are suitable for many different distributions.
When you first launch Nvu, you are presented
with what essentially amounts to a blank canvas.

This blank sheet can be daunting, but creating
Web pages with Nvu is surprisingly easy. To
demonstrate a little of what it can do, let’s create
a simple Web site.
I recently took my family to the beach, and the
grandparents have been pestering me for the
photos, so that seems like a natural place to start.
When it comes to creating a Web page, the
sky is the limit. Because this is a small site, I’m
going to try to keep things simple. The first thing I
want to do is set up a couple of tables, one inside
the other, to hold my pictures and text. Think of
tables as little boxes that you can put stuff into.
There is a fancier way of laying out a Web site,
called Cascading Style Sheets, and Nvu supports
it, but for simple sites it seems like overkill. Tables
have been used for years for basic Web page layout tasks, and they are quick and easy to set up—
exactly what I need.
To create a table in Nvu, click on the Table
menu and choose Insert→Table. A dialog box
pops up with a 6x6 grid on it. To create a table,
simply move the mouse around the grid, and click
when you have the appropriate number of rows
and columns highlighted.
The first table I want to create is simple—two
rows with a single column. I highlight them, as
shown in Figure 3, and click OK with my mouse.
Presto—I have a table.

Figure 1. Nvu Ready for Action

Figure 2. Creating a Table
Before moving on to the second table, I want
to make sure to hide the borders of this table.
Because I’m using the table for layout, I do not
want the table border to be seen. To change the
visibility of the border, I click inside one of the cells,
and then click on the Table button in the toolbar.
The Table Properties window opens, and under the
Table tab, I set the border to 0. As the rest of the
settings are fine, I click the OK button. The border
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Figure 3. Defining My Table Dimensions

Figure 4. Setting Other Table Options

can be set to any number you want, from zero up.
After setting the border to zero, you will notice
that the table is represented by colored lines instead
of black lines. Don’t worry; they won’t show when
you view the page in your Web browser.
Now, on to the second table. I want this table
to be nested or placed inside of the other table,
inside the bottom cell to be exact. To do this, I
simply click inside the bottom cell, and then go to
the Table menu and choose Insert→Table as I did
when creating the first table.
I have six pictures that I want on this page,
with some text about each picture, so for this
table, I want six rows and two columns. I highlight
the appropriate boxes until it says 6x2 and then
click OK. I then select my new table and set the
border to zero as I did with the first table.
If you’ve been following along, your Web
page should now look similar to the one shown
in Figure 5.
Before moving on, I want to save my Web
page. I want to do this for two reasons. First, saving often is a good thing to do. Second, Nvu likes
to know where the things are in relation to each
other; otherwise, it has to guess, and it can make
mistakes. Until we save the file, the changes I
have made do not really exist.
When I was getting ready to create my Web
page, one of the first things I did was create a
folder to hold all of the files. Unlike a word-processing document, items on a Web page are not
necessarily in the same file. The text and layout
portion of the Web page are in the HTML file, and
the images, movies and sounds are in separate
files. For a large Web page, this can mean hundreds of files. I don’t plan to have quite that
many, but to keep things neat and tidy, I always
create a folder to put everything in.

Figure 5. My Finished Tables, One inside the Other

Figure 6. Images for My Web Page
Because my Web page is about a trip to the
beach, I called the folder beach. I put the selected
beach photos in the folder I had prepared, along
with a title picture and a picture I prepared to use
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as the background. Having title and background
pictures is not necessary, but they can make
things look nice. All of the pictures were prepared
using The GIMP image editor included with most
Linux distributions.
One thing to be aware of when preparing
images for the Web is that, straight from your
digital camera, most pictures are far too large to
present comfortably at full size on a Web page.
For my images, I opened them in GIMP, went to
the Image menu and chose the Scale Image...
option. I then resized them to a comfortable
320x240 pixel size. I also made other modifications to make them look nice. When preparing
your images, experiment on a copy of your
images until you get results you like. I prefer to
save my images in the PNG format.
Back to the task at hand—to save my Web page,
I click on the Save icon. The first thing that happens
is a window pops up asking for the Page Title. This
is a necessary part of every Web page. I just put in
“A Day at the Beach”, and then click OK.
Now that I’ve gotten the title dialog out of the
way, a normal save dialog appears. I navigate to the
beach folder, put in a file name of index.html and
click the Save button. The reason I name this file
index.html is because that is what most Web servers
expect the first file of a Web site to be named.

Figure 7. Setting the Title of My Web Page

Now that I have saved my page, it is time to
add my title picture. To do this, I first select the
cell where I want it to appear (the big one on top)
by clicking inside the table cell, and then I click
the Image button.

Figure 8. Saving My Web Page

Figure 9. Getting Ready to Insert an Image

Next, I click on the Choose File... button and
see the Select Image File dialog, shown in Figure
10. Don’t worry about the index.html file not
showing up; this dialog shows only image files by
default. From here, I select my header.png image
and click the Open button.
After selecting the image file, I am redirected
back to the Image Properties window. I enter
some alternate text for the image and then click
the OK button. Alternate text is displayed while
the image is loading or if images are turned off. It
also is used by screen readers and other tools for
people with disabilities, so it is always a good idea
to put it in and make it descriptive.
Now that I have my title graphic in place, I can
put in all of my other pictures. The process is the
same as for the title graphic. I first select the cell
where I want the picture to be and then click on
the image button and so on.
You may notice after putting the first picture in
the nested table that the column it is in expands
to fill the screen. The other column is still there,

Figure 10. Choosing an Image
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Figure 11. Setting Image Properties

Figure 12. The Image Is Now Inserted
but it has been pushed to the side. Simply scroll
sideways until you find it, select the cell for the
second picture, and insert it as before. After you
have pictures or other content in both columns,
the cells will even out.
After placing all of my pictures, I noticed they

Figure 13. Selecting the Correct Cell to Insert the
Third Image
were not centered in their cells, so I centered
them by first selecting the picture by clicking on it
and then clicking the Align Center icon (Figure
14). It works like the equivalent icon in
OpenOffice.org and other word processors. In
fact, the other icons in the toolbar that you may
recognize work similarly to what you would
expect from working in a word processor.
I now have placed most of my pictures—all
except the background picture. To place this one, I
choose Page Colors and Background... from the
Format menu. From the Page Colors and
Background window, I can set the background
color of the page, link colors and more. I’m interested only in the background image at this point,
so I click the Choose File... button, select the file,
click on the Open button and then the OK button.
Now things are starting to look the way I want
them. I put in my text, save the file, and I am basically done. Figure 17 shows what the site looks
like in Firefox.

Figure 14. Centering the Image in the Cell

Figure 15. Setting the background image
is done here.
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Figure 19. Publishing My Web Page
Figure 17. The Newly Created Web Page

Daniel Bartholomew has been using
computers since the early 1980s when
his parents purchased an Apple IIe.
After stints on Mac and Windows
machines, he discovered Linux in 1996
and has been using various distributions
ever since. He lives with his wife and
children in North Carolina.

Figure 16. The Page Colors and Background Dialog
All that is left for me to do is add some links
and then put it on the Internet.
Links are those (usually) blue underlined words
that take you from place to place on the Internet.
Nvu makes adding links easy. Simply highlight the
text you want to turn into a link, and then click
the Link button. If you are linking to another
HTML or other file in the page folder, simply enter
its name and click on the OK button. If you are
linking to another Web site, enter in the URL
(don’t forget the http:// part). And, if you are putting in an e-mail address, make sure you check
the indicated check box.
The final step in creating a Web page is to
publish it. To publish a site from Nvu, click the
Publish button. It then prompts you for the set-

along, congratulations! You’ve just created your
own Web page! Now play around, add to it and
create your own Web site.I

RESOURCES
A lot of resources are available on-line to help you
learn more about Nvu. Here are some of my favorites:

Figure 18. Adding a Link to a Second Page
tings it needs to copy your files to the server.
Filling in this information can be the most difficult
step. Most ISPs provide customers with space on
their server to put up Web pages. Contact your
ISP for help in filling in this information.
That’s it for now. If you’ve been following

WebBriefcase: http://www.webbriefcase.com.au/
categories/how-tos/nvu
Designing & Publishing a Site with Nvu, by
Christopher Heng: http://www.thesitewizard.com/
gettingstarted/nvu1.shtml
Introduction to Nvu: http://learn.dccc.edu/~lori/nvu
forum.nvudev.org: http://forum.nvudev.org
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