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Touring The GIMP: The GNU
Image Manipulation Program
Whether you’re working on the family album or an
art-house masterpiece, there is one tool no Linux
user should be without: The GIMP.
MICHAEL J. HAMMEL

The GNU Image Manipulation Program is the most
powerful interactive image processing application for
Linux. Its user interface is based loosely on the Adobe
Photoshop image editing package. Recent releases of
GIMP have taken it to levels both amateur user and
expert artist will appreciate.
The GIMP provides many of the same features as
Photoshop, from layers and vector paths to blend
modes and text manipulation. It also goes beyond
Photoshop by providing cross-platform versions
(Linux, Mac, and Windows) as well as support for
multiple scripting languages, which makes GIMP
perfect for Web-based animation production. And,
the wealth of image filters—from blurs to clouds to
impressionistic generators—that come standard with
the base GIMP distribution can handle editing tasks
both large and small.
GIMP supports very large images through the
use of a configurable tiling scheme that makes
optimum use of available memory. The native XCF
format allows you to save all your work in layered
format. Plugins are available that allow GIMP to
integrate easily with your digital camera, scanner,
and printer. Add Inkscape, a vector graphics pro-

gram, and Scribus, a Quark Xpress-like layout program, to your editing pipeline to make any print
publication a thing of beauty.
Most recent Linux distributions now include
GIMP version 2.0. Though GIMP is not built using
the KDE environment, it works happily under it.
In this article, I introduce you to the what and
where of GIMP to provide a road map to the user
interface. In future articles and tutorials, I’ll dig
deeper into the how and why of GIMP to show
not only how various effects and tasks are performed but also why they are needed.
THE ENVIRONMENT

The working environment for GIMP consists of
three main pieces: the Toolbox, image windows,
and the working dialogs. The Toolbox is the main
window and the only window in The GIMP that
remains open all the time. It contains a set of
icons for activating basic features such as selections, painting, and transforming images. It also
holds a menu at the top, the foreground and
background color selectors, the active brush, pattern and gradients, and an optional window dock.
Image windows are where all the editing takes
place. Many image windows can be open at any
time. Each window is a composite view of an
image, based on which layers in that image currently are marked visible. Image windows have
many features. I cover these in more depth a little
later in this article.

Figure 1. The first time you start GIMP, it runs
through a number of setup windows. Once that
finishes, this layout is displayed: The GIMP
Toolbox and a vertical set of dock windows.
Working dialogs are windows that let you
work with a variety of GIMP tools, many of which
are not directly accessible from the Toolbox icons.
This includes layers, channels, paths, the undo history, and the document history.
GIMP offers plenty of configurable preferences:
full-screen mode, conservative memory use for
resource-limited systems, tear-off menus, even
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Figure 3. A slew of configurable options are available in the Preferences dialog. For slow machines
or ones with memory under 256MB, be sure to
look at the Environment options. For example,
setting fewer undo levels reduces memory
consumption.
Figure 2. Any dialog box can become a dock.
Simply drag dialog title bars onto a another dialog
title bar. This adds a tab with an icon to the dock.
Using docks, you can keep multiple dialogs open
and accessible with a click of a tab while freeing
up desktop real estate.
dynamic configuration of keyboard shortcuts.
Most of these options can be set using the
Preferences dialog (File→Preferences from the
Toolbox). Full-screen mode for any image window
can be toggled on or off by pressing F11 or by
using the View→Fullscreen menu option from the
Image Window menu bar.

THE TOOLBOX

The Toolbox is initially a vertical window of
icons attached to a single dock. The icons represent the basic set of artist tools. These
include tools for drawing and painting; creating and editing selections; performing various
transformations such as scaling, shearing, and
adding perspective; and choosing the active colors, patterns and brush types. Clicking on an
icon in the toolbox activates the tool and, if the
Tool Options dialog is open or docked, displays
the Tool Options for that tool.
The Toolbox also has a menu bar with three

Figure 4. The GIMP toolbox consists of four main
areas: 1) the menu bar, 2) the tool icons, 3) the
foreground and background colors, and 4) the
active brush, pattern, and gradient indicators.
GIMP 2.2 adds an additional preview, showing the
currently active image window to make it easier
to identify at a glance which window will be modified by the next change you make.
menus: File, Xtns, and Help. Xtns is primarily for
plugin developers, although you also can generate
predefined text logos using the Xtns→Script
Fu→Logos menu. The built-in Help system is thorough, but be sure you have The GIMP Help files
installed for your language.
The layout for The GIMP Toolbox is configurable. Stretch the window vertically and horizontally to suit your needs. Attach more docks
or detach them—the design intent was to make
GIMP’s environment as comfortable as you need
it to be.
A window dock allows you to group multiple
dialogs into a single window. Dialogs (see
File→Dialogs from the Toolbox main menu) are
available for many of GIMP’s features not
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on many features in GIMP. Experienced
users can disable tooltips from the
Preferences dialog.

NOTE:
In this article, I
often refer to the
image window as
a canvas window.
The term image
is somewhat
abused by The
GIMP community
and easily can
cause confusion
when not put
in the proper
context. Canvas
window is fairly
unique and easily
references the
GIMP image
window as a
whole, including
all associated
layers and channels. The on-line
documentation
for GIMP, however,
still refers to this
as the image
window.

THE IMAGE WINDOW

Figure 6. The toolbox tooltips describe the
icons. Tooltips are offered up in various
other places in GIMP, though these can
become annoying after you’re familiar with
the program. Disable them in the
Preferences when the time is right.
Figure 5. Tool options allow you to configure tools. The options are kept between
uses, so using a tool and making a change,
then switching to another tool, does not
cause the first tool to reset to its default
settings.
directly accessible through the Toolbox.
You can drag the dock handle (where the
dialog title is displayed) in any dialog and
drop it into any dock. The Tab menu (leftpointing arrow icon) in a dock allows you
to detach dialogs.
The first time you start GIMP, you get

both the toolbox and an additional dock
window containing two docks. This window safely can be closed if you need
the extra screen space. The tabs in the
docks can be dragged to the dock in the
toolbox if you prefer to keep them available at a mouse click. All the tabs are
dialogs that also can be accessed at any
time from the File→Dialogs menu in the
toolbox.
Leaving the mouse cursor over a tool for
a few seconds pops up a tip window, better
known as a tooltip, explaining that tool’s
basic purpose and use. Tooltips are active

The toolbox, dialogs, and docks are
tools for doing work. The place you
actually do that work is an image
window. Image windows consist of
a menu bar and a menu button,
scrollbars, rulers, a status area, and
the image display area. The image
display area shows a composite
image. Composite means all layers
and channels that currently are
marked visible are combined, in order
from bottom to top, to create the visible image. Changes made to any layer
or channel are displayed immediately
in the composite image.

Figure 7. The GIMP image window can
hide all of its features except the image
display area. It also can be displayed in
full-screen mode, which is useful for large
print projects.
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NOTE:
All visible features of an image window (except
the image display area) can be hidden from
view. Check out the options under the View
menu in the image window menu bar.

scrollbars to navigate around the image.
Alternatively, the navigation control lets you
move around the image interactively. If you
work on large images, such as those destined
for print publications, the navigation tool tends
to be a much easier way to bounce around the
image than the scrollbars.
THE FILTERS

Because not all images you create will be wide
enough to show the entire menu bar, you might
not want to use it. It can be hidden from view
using the View→Show Menubar option in the
image window. Once it’s hidden you still can get
to the same menus by using the menu button or
by pressing and holding the right mouse button
while the mouse is in the image display area.
Having multiple ways of reaching the same menus
is another way The GIMP allows you more control
of your working environment.
Rulers are provided that show the width of
an image in pixels. The rulers play a double role
in that you drag guides from them. A guide is
straight line, horizontal or vertical, that can be
used for alignment of layers or as straight edges
for drawing and selection tools. Dragging a
guide back into a ruler removes it from the
image window.
The status bar lives at the bottom of the image
window. It can display a variety of useful information in a configurable format (see the Preferences
dialog under the Interface→Image Window→Title
and Status section, and check out the on-line documentation for configuration options).
To the right of the status bar is the navigation control. The icon is a double arrow. When
the image is zoomed or larger than what the
image window can display, you can use the

Most image editing programs provide basic
tools for drawing lines, changing colors, and
scaling images. What makes tools like The
GIMP exciting is the use of filters, also known
as plugins. Filters add features to GIMP either
by providing some functionality that doesn’t
exist in the core GIMP toolbox or dialogs—say
mapping an image to a 3-D shape, such as a
cube or cylinder—or that exists only as a series
of steps with existing tools.
Image scaling, rotating, and desaturating
(that is, removing all the color and leaving an
image black and white) can be applied to a
series of images in a directory. If the same
process needs to be applied to every image, it
would be a time-consuming project to do it all
one step at a time. Filters let you turn this
process into a single dialog with a point-andclick interface.
GIMP comes with a large set of basic filters.
These are divided into menus of closely related
filters with titles such as blurs, artistic, distorts,
and render. Filters are either programs or scripts,
the latter coming in flavors of Perl, Python, and
Scheme. Filters written as scripts are similar to
Photoshop actions but far more versatile. If you
expect to do much work with animations (such
as those used on the Web) chances are good
that you’ll want to learn at least one of the

Figure 8. The Filters menu is where you find editing tools that are less interactive in general, but
more sweeping in effect, than the toolbox tools.
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Figure 9. Noise is a good starting place for textures. Add a motion blur and you get the beginnings of a brushed metal effect.
available languages.
Some of the most commonly used filters
include the Gaussian Blur (Filters→Blurs→Gaussian
Blur RLE) to simulate depth in photographs,
Noisify (Filters→Noise→Noisify) for aging photographs or as the seed for complex effects, and
Sharpen (Filters→Enhance→Sharpen) for use with
scanned photos.
When you’re in need of a specialized effect
or a good starting point for an image, try looking at the Render filters. The Plasma filter
(Filters→Render→Plasma) is often used for cre-

Figure 10. What could be more fun than going
from good to evil with only a few mouse clicks?
The iWarp filter lets you do exactly that.
ating clouds in a sky, and the Solid Noise
(Filters→Render→Solid Noise) filter is good for
simulating smoke.
Emboss (Filters→Distorts→Emboss) can turn a
2-D image into 3-D with little effort on your
part. Page Curl and Wind also often are used
and are easy-to-understand Distort filters.
Probably the most fun of the bunch is iWarp,
which can distort family photos into the true
aliens we see in our relatives.

The primary source of information for The GIMP
is the Web site, http://gimp.org. Here you’ll find
an on-line manual (in multiple languages) as
well as tutorials and various helpful tips. A
developer site (http://developer.gimp.org) is
available for anyone needing information on
writing filters for GIMP. Various on-line tutorials
also are available from users with their own
Web sites, as well as a slew of GIMP mailing lists
for both end users and developers.
All the currently available books on the
GIMP are based on a pervious version. Expect
to see new books on the GIMP 2.x series later
this year.
The truly nice thing about The GIMP is that,
although it isn’t an exact feature clone of
Photoshop, the basic functionality is quite similar. This means many of the tutorials you can
find on-line for Photoshop and in texts easily
are mapped to features found in GIMP.
Then again, if you’d rather read tutorials
written specifically for The GIMP, stay tuned to
this column. I’m just getting started!n
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